Preview Signup Error
Incident Report for QuaverEd
Resolved
The issue with new signups has been resolved and both preview signup pages are operating as expected.
Posted Oct 29, 2019 - 08:20 CDT
Identified
Signup for new preview accounts on both Quaver products is currently down. The issue is being investigated. Login at quavermusic.com/preview/dashboard and quaversel.com/preview/dashboard is still functional.
Posted Oct 28, 2019 - 14:24 CDT